Computation error after about 1 second
log in

Advanced search

Message boards : Number crunching : Computation error after about 1 second

Author Message
Admpicard999
Send message
Joined: 4 Sep 16
Posts: 3
Credit: 0
RAC: 0
Message 343 - Posted: 9 Sep 2016, 12:24:56 UTC

Hello. I'm getting "computation error" after each task runs for about 1 second. I'm running Windows with the latest BOINC client. Don't have a problem with any other projects. Is there somewhere I can check a more specific error, or anything that has worked for others to prevent this issue? I see a lot of past postings about "out of memory" but the only error I get is the "computation error" on the task status after about 1 second of running.

KaptainBlaZzed
Send message
Joined: 18 May 16
Posts: 1
Credit: 3,182,170
RAC: 0
Message 347 - Posted: 16 Sep 2016, 13:46:00 UTC - in response to Message 343.

same problem here, but only on 1 box.

Win 7 x64. has been running fine for months, now it messes up.
other projects on same machine work just fine.

all other machines Win and Linux are running fine.

Profile planetclown
Send message
Joined: 13 Jun 16
Posts: 5
Credit: 35,953
RAC: 0
Message 349 - Posted: 16 Sep 2016, 15:04:40 UTC

Try the instructions from user Snow Crash in this link:

http://vdwnumbers.org/forum_thread.php?id=60&postid=320#320

It worked for me on Win10 x64.

Admpicard999
Send message
Joined: 4 Sep 16
Posts: 3
Credit: 0
RAC: 0
Message 351 - Posted: 18 Sep 2016, 1:15:23 UTC - in response to Message 349.

Any chance of a resolution that doesn't involve any intervention? I don't intend to micro-manage tasks.

Admpicard999
Send message
Joined: 4 Sep 16
Posts: 3
Credit: 0
RAC: 0
Message 354 - Posted: 29 Sep 2016, 2:02:47 UTC - in response to Message 351.

Well, I also tried the advice at the top just to see if it would work, and unfortunately even with all other tasks suspended and a fresh restart it still fails after 1-3 seconds. Are there other possible reasons?

Profile Brian Uitti
Avatar
Send message
Joined: 14 Mar 15
Posts: 2
Credit: 4,717
RAC: 0
Message 356 - Posted: 6 Oct 2016, 22:27:05 UTC - in response to Message 349.

Try the instructions from user Snow Crash in this link:

http://vdwnumbers.org/forum_thread.php?id=60&postid=320#320

It worked for me on Win10 x64.


From Snow Crash/other thread:

I've seen this happen on one of my PCs if I happen to already be running WUs for another memory intensive project. If I suspend all tasks, reboot the PC (yes the reboot is necessary when I've seen this) and then let VDW start first I can then reactivate the WU from the other project also and everything runs fine after that.

It's almost like the prioritization gets wonky with the internal processes and VDW gets locked out - or maybe it's that VDW requires some level / amount of memory to be locked (as opposed to dynamically available) and if that's not immediately available crashes :shrug:

(not sure why I can't post on that thread... it shows me as not logged in, even though it's the next tab .. Internet Explorer 11 and FireFox!)

I'm also on Windows 10 x64 and rebooting didn't help.. I haven't had a good result since July. (although, I haven't been running it in a while.)

I may try a second machine that's also Windows 10 x64. (It has been having the same issue.)

Cheers!

// Brian
____________
Expanding the edge of Science.
[img]

Profile Beyond
Avatar
Send message
Joined: 22 Sep 16
Posts: 3
Credit: 23,058
RAC: 0
Message 357 - Posted: 10 Oct 2016, 19:00:00 UTC - in response to Message 356.

Try the instructions from user Snow Crash in this link:

http://vdwnumbers.org/forum_thread.php?id=60&postid=320#320

It worked for me on Win10 x64.

From Snow Crash/other thread:

I've seen this happen on one of my PCs if I happen to already be running WUs for another memory intensive project. If I suspend all tasks, reboot the PC (yes the reboot is necessary when I've seen this) and then let VDW start first I can then reactivate the WU from the other project also and everything runs fine after that.

It's almost like the prioritization gets wonky with the internal processes and VDW gets locked out - or maybe it's that VDW requires some level / amount of memory to be locked (as opposed to dynamically available) and if that's not immediately available crashes :shrug:

(not sure why I can't post on that thread... it shows me as not logged in, even though it's the next tab .. Internet Explorer 11 and FireFox!)

I'm also on Windows 10 x64 and rebooting didn't help.. I haven't had a good result since July. (although, I haven't been running it in a while.)

Brian, I can't post to that thread either and it seems that everyone that said the SN fix worked (on that thread) have now left the project. I'm on Win7-64 and previously the WUs have been working. Now they're also almost all failing even on a machine with large memory and disk resources (and limits checked and rechecked). PC above (who your reply is to) also seems to have dropped the project. Trying a couple new things and will report back if they work.

Profile planetclown
Send message
Joined: 13 Jun 16
Posts: 5
Credit: 35,953
RAC: 0
Message 360 - Posted: 13 Oct 2016, 18:31:55 UTC
Last modified: 13 Oct 2016, 18:50:43 UTC

I just tried a suspend all, reboot, start this project first and am only getting errors now.

<core_client_version>7.6.22</core_client_version> <![CDATA[ <message> (unknown error) - exit code -529697949 (0xe06d7363) </message> <stderr_txt> Unhandled Exception Detected... - Unhandled Exception Record - Reason: Out Of Memory (C++ Exception) (0xe06d7363) at address 0x7448A6F2

My last successful task completed on September 27th.

Still on Window 10 x64, 8G RAM using an app_config.xml with <max_concurrent>2</max_concurrent>. Same error with max_concurrent of 1.

Profile Clank [MM]
Send message
Joined: 19 Sep 16
Posts: 1
Credit: 85,369
RAC: 0
Message 363 - Posted: 25 Oct 2016, 2:41:47 UTC

After all the bad WU's were uploaded now I am being told I can only download 1 WU per day. Was running ok for awhile.
____________

DigiK-oz
Send message
Joined: 21 Mar 16
Posts: 2
Credit: 311,435
RAC: 0
Message 365 - Posted: 25 Oct 2016, 9:25:22 UTC - in response to Message 357.
Last modified: 25 Oct 2016, 9:27:15 UTC


I'm also on Windows 10 x64 and rebooting didn't help.. I haven't had a good result since July. (although, I haven't been running it in a while.)

Brian, I can't post to that thread either and it seems that everyone that said the SN fix worked (on that thread) have now left the project. I'm on Win7-64 and previously the WUs have been working. Now they're also almost all failing even on a machine with large memory and disk resources (and limits checked and rechecked). PC above (who your reply is to) also seems to have dropped the project. Trying a couple new things and will report back if they work.


Hi Beyond,

I have done some troubleshooting here as well, including ETW (event tracing for windows) which shows that the 1.8 Gig or so of memory is reserved/allocated just fine. Then milliseconds later, without any other attempts to allocate memory, the app crashes with an "out of memory" error...Linux works fine btw.

Looks like a programming error to me (several docs on the web showing how to debug/fix this, but of course only admin can do that). Is the admin testing/troubleshooting/debugging this at all?

Profile Beyond
Avatar
Send message
Joined: 22 Sep 16
Posts: 3
Credit: 23,058
RAC: 0
Message 366 - Posted: 25 Oct 2016, 15:45:16 UTC - in response to Message 365.

Hi Beyond,

I have done some troubleshooting here as well, including ETW (event tracing for windows) which shows that the 1.8 Gig or so of memory is reserved/allocated just fine. Then milliseconds later, without any other attempts to allocate memory, the app crashes with an "out of memory" error...Linux works fine btw.

Looks like a programming error to me (several docs on the web showing how to debug/fix this, but of course only admin can do that). Is the admin testing/troubleshooting/debugging this at all?

Thanks for testing this DigiK-oz. Yesterday I looked at the leading PCs, and all the Windows 7 and up boxes are now erroring all WUs. It seems that Win XP may still be working.

Stanley A Bourdon
Send message
Joined: 29 Mar 15
Posts: 3
Credit: 7,073
RAC: 0
Message 368 - Posted: 18 Dec 2016, 20:39:59 UTC

seams the project may be abandoned

this post is from the news thread

"Sorry for my recent inactivity. A paper has been posted on arxiv for this project at https://arxiv.org/abs/1603.03301, and has been submitted for publication. I would like to thank all the volunteers who contributed their resources to this project. The project will no longer generate new work, but will incorporate any results received.
____________
Daniel Monroe
vdwnumbers.org Project Administrator"
____________


Post to thread

Message boards : Number crunching : Computation error after about 1 second


Main page · Your account · Message boards


Code and content created by Daniel Monroe © 2018.